XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Conferences Close Tree View
+ Stylus Studio Feature Requests (1172)
- Stylus Studio Technical Forum (14502)
-> + Stylus Studio with OpenJDK (2)
-> - Encoding error when importing ... (1)
-> - SEO Service in Delhi, India (1)
-> - HP Printer Support (1)
-> + Stylus Studio X16 Professional... (5)
-> + Stylus Studio X16 Enterprise -... (4)
-> - Overly complicated formatting ... (1)
-> + java apparently running, canno... (2)
-> + Stylus on Citrix - unable to v... (6)
-> + XSLT and XPath Questions (New ... (13)
-> + EDIFACT D96A CONTRL XML schema (2)
-> + JDK dropdown box empty and Jav... (2)
-> + Replacing XSD files in Report (4)
-> + Cannot locate WYSIWIG tab on X... (3)
-> + EDI X12 xml schema with segmen... (2)
-> + Error Message (4)
-> + jvm disabled message keeps pop... (2)
-> + XTSE0620: An xsl:param element... (3)
-> + Fail in installing ďApache FOP... (5)
-> - Jenkins: about the path of bui... (1)
-- [1-20] [21-40] [41-60] Next
+ Website Feedback (247)
+ XSLT Help and Discussion (7595)
+ XQuery Help and Discussion (1944)
+ Stylus Studio FAQs (159)
+ Stylus Studio Code Samples & Utilities (364)
+ Stylus Studio Announcements (113)
Topic  
Postnext
Geert BormansSubject: Saxon XSLT2 and FOP for XSL:FO in Pipelines
Author: Geert Bormans
Date: 21 Apr 2009 06:03 AM
Hey,

I am using a pipeline to do some XSLT2 transform and then use FOP to generate PDF.
This works fine, but...
it seems that the Saxon XSLT2 included is an old v8 and that the FOP included is still 0.20
That is way too old for my purposes.

How can I upgrade to newer Saxon and FOP in a pipeline, if at all possible.
And where would I find the FOP configuration

Thanks

Geert

Postnext
Tony LavinioSubject: Saxon XSLT2 and FOP for XSL:FO in Pipelines
Author: Tony Lavinio
Date: 21 Apr 2009 10:37 AM
Stylus Studio 2009 ships with Saxon 9, and 2009r2 with 9.1.0.5.
While it is true that Apache FOP is still .20.5, you can use
an external post-processor to run FOP .9x, or use the bundled
RenderX XEP processor.

Posttop
Geert BormansSubject: Saxon XSLT2 and FOP for XSL:FO in Pipelines
Author: Geert Bormans
Date: 21 Apr 2009 04:23 PM
OK, thanks,
I will use XEP for now
thank you for your answer

   
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.