XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to next topicNext Topic
Postnext
Robin SmithSubject: Text symbols in SS not same as final doc
Author: Robin Smith
Date: 23 Jun 2022 08:50 PM
I have a document with the symbol: within the document. It is working properly within Stylus Studio when the post processing preview completes. Once it is put into our system and a final PDF document is created there are issues. Please see the screenshots for more clarity.


UnknownSSDocsymbols.PNG
example of Stylus Studio working

UnknownPDFDocsymbols.PNG
final PDF with issues

Postnext
Ivan PedruzziSubject: Text symbols in SS not same as final doc
Author: Ivan Pedruzzi
Date: 23 Jun 2022 09:16 PM
Robin,

This seems to be a problem triggered by the wrong character encoding.

What did you set as output encoding in your XSLT?

Which XSL-FO processor do you use in production?

Which XSL-FO processor have you configured in the Stylus Studio scenario?


Ivan Pedruzzi
Stylus Studio Team

Postnext
Robin SmithSubject: Text symbols in SS not same as final doc
Author: Robin Smith
Date: 24 Jun 2022 03:04 PM
Ivan,

This is an older document that I was handed and asked to update verbiage and formatting on. The output in our document system is FOP to create a PDF. I will add a screenshot for you.

Here is the first several lines of the code:

<?xml version="1.0" encoding="utf-8"?>
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:fo="http://www.w3.org/1999/XSL/Format" version="1.1" xmlns:saxon="http://icl.com/saxon" extension-element-prefixes="saxon" xmlns:fox="http://xml.apache.org/fop/extensions">
<xsl:template match="*|@*">
<xsl:apply-templates select="*|@*"/>
</xsl:template>
<xsl:template match="CO">
<!--The font-family that you declare here is used throughout the document-->
<fo:root xmlns:fo="http://www.w3.org/1999/XSL/Format" font-family="Times" font-size="12pt">
<!--Here is the size of the page you will be creating-->
<!--pt stands for a point. There are 72 pointes to an inch-->
<fo:layout-master-set>


UnknownDocSystemsetup.PNG
production info

Unknownpostprocessing.PNG
post processing

Posttop
Ivan PedruzziSubject: Text symbols in SS not same as final doc
Author: Ivan Pedruzzi
Date: 24 Jun 2022 06:16 PM
Unfortunately the screenshot does not help to determine which XSL-FO processor your production software is using.

Could you please try to add the following line just before <xsl:template match="*|@*">
<xsl:output method="xml" encoding="UTF-8" indent="yes"/>

This should make sure that the XSLT encoding output is UTF-8

could you please zip your XSLT and XML input files and sent it to stylussupport@ivitechnologies.com.


Ivan Pedruzzi
Stylus Studio Team

 
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.