XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Conferences Close Tree View
+ Stylus Studio Feature Requests (1188)
- Stylus Studio Technical Forum (14588)
-> + Text symbols in SS not same as... (4)
-> + Exposing xquery as webservice ... (2)
-> + Syntax Identifier (2)
-> + Saving a Converted XML as an X... (5)
-> + Output document cannot be pars... (4)
-> - Archiving output from conversi... (1)
-> + EDIFACT guideline from Stylus ... (3)
-> + CSV file putting all the data ... (5)
-> + Can't install Home version 64b... (5)
-> + presale - Can I covers this sc... (5)
-> + Problem with UNB (5)
-> + Splitting EDIFACT files pipeli... (4)
-> + Problem with SAXO processor - ... (5)
-> + PDF Format Help (4)
-> + License check unreliable (2)
-> - XML related issue (1)
-> + Need help regarding pipeline o... (2)
-> + Error converting XML to EDIFAC... (4)
-> + XSLT Profiling for XSLT 1.0 s... (2)
-> + Grouping (2)
-- [1-20] [21-40] [41-60] Next
+ Website Feedback (247)
+ XSLT Help and Discussion (7617)
+ XQuery Help and Discussion (1971)
+ Stylus Studio FAQs (159)
+ Stylus Studio Code Samples & Utilities (364)
+ Stylus Studio Announcements (113)
Topic  
Postnext
Charlie CoxSubject: stylus 2.0 problem with template parameter
Author: Charlie Cox
Date: 29 Mar 2000 02:18 PM
I am trying to execute the following xsl and Stylus 2.0 is not recognizing one of my parameters in the countValue template on the first pass of this recursive template. The results of this xsl are also included below. As you can see, the index parameter starts at '2' and after adding '1' to it, it becomes '1'. All future iterations provide the value correctly. '0' is the only starting value without this problem.

Any suggestions?

thanks,
Charlie











2
4






index=

add 1 to index=
newindex=
---------------------












--------------------------------------
the xml:
--------------------------------------



10



--------------------------------------
the results:
--------------------------------------

index=2
add 1 to index=1
newindex=1
---------------------

index=1
add 1 to index=2
newindex=2
---------------------

index=2
add 1 to index=3
newindex=3
---------------------

index=3
add 1 to index=4
newindex=4
---------------------

index=4
add 1 to index=5
newindex=5
---------------------

Posttop
Omri TraubSubject: stylus 2.0 problem with template parameter
Author: Omri Traub
Date: 29 Mar 2000 02:28 PM
Hi,

This is indeed a problem with Stylus which will be fix in the next point release. There is an easy work-around though:

Instead of:

(xsl:with-param name="index")2(/xsl:with-param)

do this:

(xsl:with-param name="index" select='2'/)

- Omri

   
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.