[XSL-LIST Mailing List Archive Home] [By Thread] [By Date] [Recent Entries] [Reply To This Message]

Re: XSL Variable not getting set

Subject: Re: XSL Variable not getting set
From: Abel Braaksma <abel.online@xxxxxxxxx>
Date: Wed, 14 Mar 2007 14:42:27 +0100
Re:  XSL Variable not getting set
Abel Braaksma wrote:
mIchael wolff wrote:

right to the line: <xsl:if test="not(Found)">

As a consequence, your line with '<xsl:if test="not(Found)"> ' is the first stop for the debugger (nothing else to do before that).




others seem to have had sharper eyes than I ;)
If you were using the variable, I think my story may still hold, but, as others have pointed out, you are testing for a node 'Found' not for the contents of a variable '$Found'. Hence even more reasons for the processor to skip your variable altogether.


Cheers,
-- Abel Braaksma

Current Thread

PURCHASE STYLUS STUDIO ONLINE TODAY!

Purchasing Stylus Studio from our online shop is Easy, Secure and Value Priced!

Buy Stylus Studio Now

Download The World's Best XML IDE!

Accelerate XML development with our award-winning XML IDE - Download a free trial today!

Don't miss another message! Subscribe to this list today.
Email
First Name
Last Name
Company
Subscribe in XML format
RSS 2.0
Atom 0.3
Site Map | Privacy Policy | Terms of Use | Trademarks
Free Stylus Studio XML Training:
W3C Member
Stylus Studio® and DataDirect XQuery ™are products from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2013 All Rights Reserved.