XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Go to previous topicPrev TopicGo to next topicNext Topic
Postnext
rajat nairSubject: getting the value of an attribute
Author: rajat nair
Date: 10 Jan 2008 09:54 AM
Hi,
I wanted to get the value of an attribute, for example
<trade:tag1 xmlns:trade="http://www.example.com/default" payloadID="12345678912@blah.com">
I want to get the value of payload id,but whn i try to do a regular mapping i get value and name, which is payloadID="12345678912@blah.com,which is going as a attribute value for the tag i m mapping it to and not as content for the tag.For example

<ID payloadID="12345678912@blah.com">

The way i wanted it to show is as shown below
<ID>12345678912@blah.com<ID>

Any help would be greatly appreciated.

Regards
Rajat Nair


Postnext
Alberto MassariSubject: getting the value of an attribute
Author: Alberto Massari
Date: 10 Jan 2008 03:49 PM
Hi,
if I drag the attribute to an element in the target schema of an XQuery mapper, I get the value of the attribute as the text of the element, e.g.

<xxx>
{data(/root/test/@number)}
</xxx>

Can you explain how you are creating the link?

Thanks,
Alberto

Postnext
rajat nairSubject: getting the value of an attribute
Author: rajat nair
Date: 10 Jan 2008 05:03 PM
>Hi,
>if I drag the attribute to an
>element in the target schema
>of an XQuery mapper, I get the
>value of the attribute as the
>text of the element, e.g.
>
> <xxx>
> {data(/root/test/@number)}
> </xxx>
>
>Can you explain how you are
>creating the link?

i m using the mapping utility of xquery.When i do a one on one mapping from xml A to xml B, i get the value and name of the attribute from xml A as a attribute for a element in xml b

tag in xml A
<trade:tag1 xmlns:trade="http://www.example.com/default" payloadID="12345678912@blah.com">

after i do a simple one on one mapping with this tag and a tag " <ID>" in xml B i get <ID payloadID="12345678912@blah.com"> instead of

<ID>12345678912@blah.com<ID>
Thank you for the prompt response.

Regards
Rajat



>Thanks,
>Alberto

Posttop
Minollo I.Subject: getting the value of an attribute
Author: Minollo I.
Date: 10 Jan 2008 05:14 PM
I guess there is something else going on in your XQuery, as I can't reproduce the behavior you are describing using XQuery mapper.

Maybe you can email us (stylus-field-report@progress.com) or attach the XQuery, source and destination documents you are using?

 
Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.