XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Postnext
David BrownSubject: XSL cannot save: I/O error...being used by another process (8r2 Pro)
Author: David Brown
Date: 13 Jul 2007 10:23 PM
Originally Posted: 13 Jul 2007 10:05 PM
I am writing some very simple XSL templates (maybe 10 tags total) in stylus studio. I'm just learning XSL and so I get plenty of errors. After about the second error, I can no longer save the file I'm working on. The dialog reads:

Encountered an I/O error in URL "file:///c:/Documents and Settings/...myfile.xsl" The process cannot access the file because it is being used by another process.

All files involved are part of the project and are not being used by any process not started by Stylus Studio. (I copy/paste the XSL into my PHP scripts.)

This may be associated with the appearance of a little bouncing line below the editor that holds a copy of the XSL error message. Not sure.

If I close and reopen the file, I am still unable to save changes to the XSL. While the file is closed, Process Explorer still shows that struzzo.exe has a file handle open to it.

The problem appeared after I upgraded to Build 894i (current as of July '07) of Stylus Studio Professional Suite. However, I don't use it much, so its possible I might not have noticed the problem in the earlier version. Still. I am going to try reinstalling the previous version. This problem is getting too annoying.

Thanks for any help.

EDIT: a few more bits of information.

I can NOT find a file handle to the .xsl (examining Struzzo.exe with Process Explorer) when I simply open the file. There is one very briefly while the XSL runs. Also to a tmp file (perhaps for output)

If I deliberately introduce an error and make the editor window very wide such that the error message fits within the status bar below the editor, the handle appears to close properly.

If I have the editor window narrow enough that the error message bounces from side to side, the file handle remains, I cannot save the file, and once I try and fail, I can't run the xsl either.

Hope that helps you pin it down. Now, "onward" back to 8r1 instead of 8r2. Hopefully I can still open my project files...

Postnext
David BrownSubject: XSL cannot save: I/O error...being used by another process (8r2 Pro)
Author: David Brown
Date: 13 Jul 2007 11:07 PM
update:
I cannot reproduce this problem in 8r1 (framework build 735f; all modules match). The About screen shows my Java VM to be 1.6.0_01-b06 Java HotSpot(TM) Client VM Sun Microsystems Inc.

Is there a way to turn off new version notifications? (Well, I could remove the exception in the firewall...) I might be staying at this version for a while.

PS, I wasn't kidding about how simply my XSL is... in fact, I exaggerated by a factor of three; there are only 3 tags! I was simply trying to extract the grand total from a United Parcel Service shipping rate response:

<?xml version='1.0' ?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:template match="/"><xsl:value-of select="RatingServiceSelectionResponse/RatedShipment/TotalCharges/MonetaryValue"/>
</xsl:template>
</xsl:stylesheet>

Postnext
Alberto MassariSubject: XSL cannot save: I/O error...being used by another process (8r2 Pro)
Author: Alberto Massari
Date: 17 Jul 2007 01:19 PM
Hi David,
you can disable the check for new versions from the Tools | Options dialog (Application Settings, Check for newer version check boxes).
As for the locked file, which processor are you using?

Thanks,
Alberto

Postnext
David BrownSubject: XSL cannot save: I/O error...being used by another process (8r2 Pro)
Author: David Brown
Date: 17 Jul 2007 01:33 PM
When I open the dialog in 8r1 -- remembering the problem showed up in 8r2 -- it shows Saxon 8.7.3.

I honestly don't recall selecting a processor at any point during this project, but this does appear to be different from the default "built-in". It's the first option in the list.

Postnext
Alberto MassariSubject: XSL cannot save: I/O error...being used by another process (8r2 Pro)
Author: Alberto Massari
Date: 18 Jul 2007 11:23 AM
Hi David,
do you recall the type of error that was reported (invalid XML, wrong syntax for an XSL instruction...)?
Does the lock occur also when the 'Use Stylus Studio URI Resolver' checkbox in the Processor tab of the scenario dialog is cleared?

Thanks,
Alberto

Postnext
David BrownSubject: XSL cannot save: I/O error...being used by another process (8r2 Pro)
Author: David Brown
Date: 18 Jul 2007 01:18 PM
I remember that one silly error I made and that resulted in this issue was to drag-and-drop from the tree to a point past the </xsl:stylesheet> tag, creating an out-of-place <xsl:template>. Redoing that gives (in r1):

SXXP0003: Error Reported by XML Parser: The markup in the document following the root element must be well-formed.

"Use Stylus Studio URI Resolver" is *not* checked. I know what the words mean, but I don't know whether I'd want it or not, so I hadn't touched it.


I'm starting to get a feeling that maybe when I was working in a different project setting up Sablotron and expat as a custom parser (a project that depended more heavily on the eccentricities of PHP) some defaults outside of the project scope maybe got whacked?

So far, you've mentioned using the built-in parser and the URI resolver setting. I'm thinking I will try reinstalling r2, changing those settings to (built-in, enabled) and seeing whether the problem persists.

Anything else I might look for? Thanks very much for the suggestions so far.

Postnext
Alberto MassariSubject: XSL cannot save: I/O error...being used by another process (8r2 Pro)
Author: Alberto Massari
Date: 19 Jul 2007 07:16 AM
Hi David,
thanks for describing the kind of error that was present; we have been able to reproduce it and we are working to fix it.
For the record, it only appears with Saxon if you uncheck the 'Use Stylus Studio URI Resolver', so a quick workaround is to enable it (its purpose it to let Stylus Studio open all the files needed to perform the transformation, and must be enabled if you are using custom URL like converter://, xquery://, tiger:// or wscc:// to run Convert-To-XML or access relational databese, Web Services or TigerLogic servers).

Thanks,
Alberto

Posttop
David BrownSubject: XSL cannot save: I/O error...being used by another process (8r2 Pro)
Author: David Brown
Date: 20 Jul 2007 10:55 AM
I have gone back to r2 and selected the built-in XSL processor (which forces SS URI resolver on). I wasn't able to reproduce the problem in half a dozen attempts. Thank you.

 
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.