XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Go to previous topicPrev TopicGo to next topicNext Topic
Harish DeshpandeSubject: Help Creating a new wsdl
Author: Harish Deshpande
Date: 06 Nov 2006 10:32 AM
I am sorry if I am posting this in the wrong forum.
Have gone through the documentation and could not figure out a way of creating a new wsdl for a web service I intend to create(not call). How can I go about doing this?

I tried opening a wsdl I had created and when I tried to open it in SS I get the error: Unsupported URL scheme """"

Thanks in advance.

Here is the wsdl:
<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"

xmlns:xsd = "http://www.w3.org/2001/XMLSchema"
elementFormDefault = "qualified"
targetNamespace = "http://localhost:8080/ReqResp">
<xsd:import namespace = "tws"
<xsd:import namespace = "http://www.w3.org/2001/XMLSchema" />

<wsdl:message name="Request">
<wsdl:part element="types:Person" name="pers"/>
<wsdl:message name="Response">
<wsdl:part element="types:Order" name="ordr"/>

<wsdl:portType name="wsdl01PortType">
<wsdl:operation name="getOrder">
<wsdl:input message="tns:Request"/>
<wsdl:output message="tns:Response"/>

<wsdl:binding name="getOrderSOAPBinding" type="tns:wsdl01PortType">
<soap:binding style="message"
transport="http://schemas.xmlsoap.org/soap/http" />
<wsdl:operation name="getOrder">
<soap:operation style="message" soapAction="getOrder" />
<soap:body use="message" />
<soap:body use="message" />

<wsdl:service name="getOrderService" >
<wsdl:port name="getOrderSOAPPort"
location="http://localhost:8080/AxisWeb/services/ReqResp" />


The schema that is referenced is:
<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" targetNamespace="tws" xmlns="tws">
<xs:element name="Order">
<xs:element name="OrderNumber" type="xs:string"/>
<xs:element name="Status" type="xs:string"/>
<xs:element ref="Person"/>
<xs:element name="Person">
<xs:element name="Name" type="xs:string"/>
<xs:element name="Street" type="xs:string"/>
<xs:element name="City" type="xs:string"/>
<xs:element name="State" type="xs:string"/>
<xs:element name="PostalCode" type="xs:string"/>


Tony LavinioSubject: Help Creating a new wsdl
Author: Tony Lavinio
Date: 17 Nov 2006 09:01 AM
Probably when you tried to open it, you used the Web Service
Call Composer instead of the XML Editor.

You can fix the file association under Tools|Options.

You may want to read up on the WSCC to see how it relates to
WSDL files in the documentation. It is not a WSDL editor, but
is used to call web services that themselves expose WSDL.

Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.