XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Postnext
Kasimier BuchcikSubject: How to update Saxon 8.1.1 to Saxon 8.7.1 in SS Home Edition 6
Author: Kasimier Buchcik
Date: 11 May 2006 09:51 AM
Hi,

I'm using the Home Edition 6 (not 2006), release 2, build 287n.
The Saxon XSLT processor which comes with this edition is Saxon 8.1.1.

Now I would like to update to Saxon 8.7.1.
My first naive step was to exchange the saxon8.jar in the bin
directory of SS, but I'm getting the following error when
trying to run a transformation:

"Internal error accessing method in Xalan Driver
java.lang.NoClassDefFoundError: net/sf/saxon/xpath/XPathException"

Postnext
Minollo I.Subject: How to update Saxon 8.1.1 to Saxon 8.7.1 in SS Home Edition 6
Author: Minollo I.
Date: 11 May 2006 10:13 AM
You can't manually change the version of the bundled Saxon processor.

I would suggest that you move to a more recent version of Stylus Studio; but in alternative you can configure a different Saxon version as an external custom processor (specifying command line and classpath in the proper fields in the Scenario dialog).

Minollo

Postnext
Kasimier BuchcikSubject: How to update Saxon 8.1.1 to Saxon 8.7.1 in SS Home Edition 6
Author: Kasimier Buchcik
Date: 11 May 2006 02:32 PM
Moving to a recent version would implicate paying for a recent
version, just to be able to update Saxon, right?... I don't see
sane relations here.

The 1 slot for the external custom processor is already
in use on my side for an XSLT processor which I'm currently
refactoring.

If the calls to Saxon are not hard-coded in the main
application, but in an intermediate (Java ?) layer, then it
should be possible for Stylus Studio team to update such
an intermediate layer. But that's just an assumption.

So there's definitively no way to use an other Saxon version
than the one bundled with my Stylus Studio? There's no support
for such scenarios?



Posttop
Minollo I.Subject: How to update Saxon 8.1.1 to Saxon 8.7.1 in SS Home Edition 6
Author: Minollo I.
Date: 11 May 2006 04:07 PM
The Saxon version bundled with Stylus Studio is closely coupled to supporting modules to expose debugging and profiling; that what makes upgrading that version not as easy as copy and pasting a new jar file.

The two options I mentioned are the only ones currently supported to upgrade version of the bundles Saxon version. For the record, if you upgrade to the latest Enterprise Edition, you'll get access to the commercia Saxon SA version.

Minollo

 
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2011 All Rights Reserved.