XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Marcus van RaalteSubject: Running "Convert to XML" - failing
Author: Marcus van Raalte
Date: 25 Feb 2005 07:51 PM
I have just reloaded stylus studio and tried to use the convert to sml for a flat-file and it complains that "Java Runtime Environment library not found" - Now I am sure that in your world no-one would have a system without the latest and greatest JVM on their system. I have no other need for such a thing - and indeed wish that using your product did not require it - but so be it. The problem is that (a)It neither installed it nor asked me if I would like to have it installed. (b)Now although it tells me it is needed it neither offers to install it for me, nor does it tell me how. Please, Please tell me why you make something I really do NOT want to do very tuff to do? Making it even more painful that it has to be.

Anyway, thanks

Marcus van Raalte

Minollo I.Subject: Running
Author: Minollo I.
Date: 25 Feb 2005 08:53 PM
only some Stylus Studio functionality require a 1.4 or 1.5 JVM to be available on the system. Convert-to-XML is one of those.

We don't bundle a JRE in Stylus Studio to avoid making the installation package too large for many people to download, because most users have a JVM already available on their systems (even if they may not be aware of it), and because in those cases in which a JVM is not already present, developers tend to be quite religious about what software and which version gets installed.
That said, there are definitely ways in which we can make life easier when a JVM is not available and you try using a Stylus Studio functionality that requires it, and we are working on that in the context of the improvements that will be part of the next Stylus Studio version.

In the meanwhile, you can find a JRE installation (which is what you need) under http://java.sun.com/j2se/1.5.0/download.jsp; just run the JRE installer, restart Stylus Studio and things should work as expected.

Hope this helps,

Marcus van RaalteSubject: Running
Author: Marcus van Raalte
Date: 25 Feb 2005 09:56 PM
Originally Posted: 25 Feb 2005 09:55 PM
Minollo,<br> <br> Thanks for the information, I guess you intend me to install jre-1_5_0_01-windows-i586 etc.<br> <br> I agree it makes sense that it is not a built in piece of the install.<br> <br> I tried in a light harted fashion, to show that it should at least make it very easy to install, when it really is needed. It should obviously include the necessary questions and warnings that make sense. <br> <br> Also, although I may be in the minority of the current users, as you grow....<br> <br> Of course it would be even better if you could do without these SUN componenets altogether - etc. etc.<br> <br> Thanks again<br> <br> Marcus

Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.