XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Postnext
(Deleted User) Subject: stylus validator
Author: (Deleted User)
Date: 19 Jul 2004 06:09 AM
I am running this and I get an error in a schema yet when I run the
internal validator I do not get an error.

Can you please tell me which version of the validators are working in both cases.

Also I problems with the xerces J I get the following:

Xerces Java 2 Validation Starting.
file:///s:/schemas/Application/Order.Notification.xsd:4,344: (Error) cvc-elt.1: Cannot find the declaration of element 'xsd:schema'.


I have also tried using the xquery validate from te command line as I sent last week.

It seems that the commandline works differently from the studio as the studio works and the other complains.


UnknownOrder.Notification.xsd

Posttop
Alberto MassariSubject: stylus validator
Author: Alberto Massari
Date: 20 Jul 2004 06:51 AM
Hi Martin,

>I am running this and I get an error in a schema yet when I
>run the internal validator I do not get an error.
>
>Can you please tell me which version of the validators are
>working in both cases.

I have tried to validate the schema you attached, and I get two errors
using both the internal validator of the IDE and the command line
version.
BTW, this schema references Order.ServiceRequest.xsd and Order.xsd; I
assumed they were the same you already sent us a while ago.

>Also I problems with the xerces J I get the following:
>
>Xerces Java 2 Validation Starting.
>file:///s:/schemas/Application/Order.Notification.xsd:4,344:
>(Error) cvc-elt.1: Cannot find the declaration of element
>'xsd:schema'.

Xerces-J is not able to validate XMLSchemas, only XML document bound
to an XMLSchema, so this is expected.

>I have also tried using the xquery validate from the command line
>as I sent last week.
>
>It seems that the commandline works differently from the
>studio as the studio works and the other complains.

That would be very strange, as they share the same validator engine;
the only difference is that the IDE validator works on the buffer you
are currently editing. Can you verify if you have different results
when you have unsaved schemas opened in the IDE?

Alberto

 
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.