XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Conferences Close Tree View
+ Stylus Studio Feature Requests (1188)
- Stylus Studio Technical Forum (14584)
-> + Berkeley XML DB (4)
-> + What is the context node in th... (3)
-> + Multi element List (4)
-> + Cannot preview XSL transformat... (9)
-> + Why is this variable not showi... (7)
-> + Customising Schema Prefix (3)
-> + Please help!! XML AND XSL Tra... (6)
-> + XML to Excel in Home Edition (2)
-> + how to copy elements from an x... (2)
-> + Setting Saxon parameters in pi... (2)
-> + Trying to move SS license (3)
-> + Does SS PRO Support CSS (2)
-> + Selected values are not showin... (3)
-> + Copy Xpath To Clipboard Option... (2)
-> + Upgrading to SS 2006 3 - Activ... (3)
-> + XSL Efficiency tips (4)
-> - Report page Size and table hea... (1)
-> + Endless loop with xquery (8)
-> - Xpress XML (1)
-> + Extracting XML data into SQL s... (2)
-> + Crashes when I save (2)
-> + XSL cannot save: I/O error...b... (8)
-> + Diagram view has disappeared f... (5)
-> + Convert from http://www.w3.org... (2)
-> + Round-trip Converting; CSV-XML... (2)
-> + XSL error function call PHP (8)
-> + WYSIWYG XSLT Designer (5)
-> + generate xhtml+css from xml re... (2)
-> + generate xhtml+css from xml re... (3)
-> + generate xhtml+css from xml re... (2)
-> - Help using xsd xs:redefine nee... (1)
-> + Data loss opening External sch... (2)
-> + Install Apache FOP Plugin with... (8)
-> + Generating a Publisher Canvas ... (2)
-> + Stylus Studio comment block no... (3)
-> + Report Designer Screen Repaint... (5)
-> + validating on values (5)
-> + reuse of xslt (2)
-> + The evaluation period for the ... (2)
-> + export to documentation (3)
-> + Validating XML files using sev... (2)
-> + Missing 'Command' Tab in Custo... (3)
-> + Do I have to download new vers... (6)
-> + Can SS validate tags used in a... (5)
-> + validating schemas (2)
-> + Off-Topic Question - Looking f... (4)
-> + cannot see anything in mapper ... (2)
-> + Validating XSD schema sets (7)
-> + Standard Validation Engines (3)
-> + Style Sheet amendment to inclu... (2)
-> + Documentation - prevent import... (3)
-> + Debugging breakpoints with Sax... (17)
-> + Conversion (3)
-> + New and I am sure this is an e... (7)
-> + Saxon 8 with multiple xml inpu... (3)
-> + Compilation error (5)
-> + webservice call failing - pls ... (3)
-> + C# from Java Binding Classes (3)
-> + Java binding class generation (5)
-> + Validation of deeply-nested sc... (5)
-> + How to make Drag and drop in X... (2)
-> + Malformed XPATH expression par... (5)
-> + Toolbars and missing options (4)
-> + Converting Text File (2)
-> + Java Heap Issue (2)
-> + Formatting SOAP messages (6)
-> + Attribute Entity Expansion on ... (2)
-> + Text File to xml conversion wi... (9)
-> + Different XPath results when u... (7)
-> + Where is my XSLT mapper module (3)
-> + Where is my XSLT WYSIWYG Edito... (2)
-> + Regarding Stylus support of IA... (2)
-> + Debugging Problem with Enterpr... (5)
-> + various report designer prob;e... (12)
-> - will it EVER get fixed ?? Stru... (1)
-> - Migrate from wysiwyg xslt edit... (1)
-> + Entity Resolver in UI? (4)
-> + Visual Studio and Stylus Studi... (2)
-> + how to get rid of parameter in... (8)
-> + XQuery file (2)
-> + 505 error calling a WS from SS... (2)
-> + Configure Subversion with Styl... (2)
-> + XSLT Mapping of xsi:nil and xs... (2)
-> + Printing values in a table or ... (2)
-> + query on using stylus API for ... (12)
-> + WSDL retruns no response (2)
-> + SS XSL Processor Bug: Count() (6)
-> + Stylus Studio crashes after re... (2)
-> + Custom Converter in IBM JVM is... (10)
-> + Malformed XPATH epressions on ... (4)
-> - XML Report table borders when ... (1)
-> + XML Publisher Generation of XS... (3)
-> + SS Error: Segment UNB: Segment... (6)
-> + SS Enterprise 2007 R2 does not... (2)
-> + Generating XSD from XML - glob... (3)
-> + SS Enterprise 2007 R2 does not... (2)
-> + SS dies on xsl files loads (7)
-> + EDIFACT UNA section ? (3)
-> + SS closes when I attempt to sa... (2)
-> + Support for SPEC 2000 & genera... (6)
-- Previous [1501-1520] [1521-1540] [1541-1560] Next
+ Website Feedback (247)
+ XSLT Help and Discussion (7617)
+ XQuery Help and Discussion (1971)
+ Stylus Studio FAQs (159)
+ Stylus Studio Code Samples & Utilities (364)
+ Stylus Studio Announcements (113)
Topic  
Postnext
(Deleted User) Subject: XPath Drag & Drop from XML-File doesn't work
Author: (Deleted User)
Date: 27 Sep 2001 05:17 AM
Hi

I'm using Stylus Studio 3.1.9 #59a and have found some bad behavior.

1) Feature request
A great help in the "Scenario Properties" dialog would be, if the "Parameter Values" would be sorted by name. If you have a long list of parameters, than it is very difficult to find the right one, especially if the parameters have similar names (e.g. a prefix "param_Xte_ORD_XXXXXX").

2) When I have a {xsl:for-each select="$varQuery"} construct, than it is not possible to drag & drop any values from the XML-Schema on the right to the stylesheet (the nice pop-up doesn't come). (Please see the attached XML/XSL file for further information.) But it would be nice to use the "insert node name" menu item from the pop-up.

Thank you

Chris


DocumentTestCase.xml
TestCase.xml

DocumentTestCase.xsl
TestCase.xsl

Postnext
Minollo I.Subject: Re: XPath Drag & Drop from XML-File doesn't work
Author: Minollo I.
Date: 27 Sep 2001 10:12 AM

>...
>1) Feature request
>A great help in the "Scenario Properties" dialog would be, if the
>"Parameter Values" would be sorted by name. If you have a long list of
>parameters, than it is very difficult to find the right one, especially if
>the parameters have similar names (e.g. a prefix "param_Xte_ORD_XXXXXX").

Sounds more than reasonable. I'm adding this to our PCR list, and it will
be done soon.

>2) When I have a {xsl:for-each select="$varQuery"} construct, than it is
>not possible to drag & drop any values from the XML-Schema on the right to
>the stylesheet (the nice pop-up doesn't come). (Please see the attached
>XML/XSL file for further information.) But it would be nice to use the
>"insert node name" menu item from the pop-up.

We understand what you are saying. We'll look into it.

Thanks,
Minollo

Postnext
Minollo I.Subject: Re: XPath Drag & Drop from XML-File doesn't work
Author: Minollo I.
Date: 28 Sep 2001 05:51 PM
Both problems are fixed in BL63, 3.1 Beta 4

Thanks for reporting them,
Minollo

Postnext
Kent WolfSubject: Re: XPath Drag & Drop from XML-File doesn't work
Author: Kent Wolf
Date: 10 Mar 2003 05:34 PM
Howdy!

I've been searching through your Web-board here and it looks this set of postings relates to exactly the problem I'm having. I'm currently using version 4.6 build 103q.

The problem relates to #2 stated above. Before I upgraded to 4.6, I was able to drag and drop from a schema on the right-hand side and get a pop-up window in the XSLT. From there I could get the full path to the element or simply the element name. Now when I do the drag and drop it puts the following in to my stylesheet:




Is there any way to change the settings in this newer version to get the same drag and drop functionality that I previously enjoyed?

Thanks.

Postnext
Minollo I.Subject: Re: XPath Drag & Drop from XML-File doesn't work
Author: Minollo I.
Date: 10 Mar 2003 05:43 PM
I can see the behavior you are describing only if I drag&drop outside of
any template in the stylesheet; if I drag&drop an item from the schema
inside a template, I get the pop-up menu where I can choose the action to
perform...

Is the behavior you are describing the same for any stylesheet you are using?

Minollo

Postnext
Kent WolfSubject: Re: XPath Drag & Drop from XML-File doesn't work
Author: Kent Wolf
Date: 12 Mar 2003 05:40 PM
On 3/10/03 5:43:44 PM, Carlo Innocenti wrote:
>I can see the behavior you are
>describing only if I drag&drop
>outside of
any template in
>the stylesheet; if I drag&drop
>an item from the schema
>
inside a template, I get the
>pop-up menu where I can choose
>the action to
perform...

Is
>the behavior you are
>describing the same for any
>stylesheet you are
>using?

Minollo

Actually, that is the functionality I'm looking for. Even when I drag&drop an element to within a template, I still get the begin template, match "element", and end template.

And yes, I have the same behavior for all stylesheets that I am using.

Thanks,
Kent


Posttop
Minollo I.Subject: Re: XPath Drag & Drop from XML-File doesn't work
Author: Minollo I.
Date: 12 Mar 2003 08:35 PM
This is pretty weird. I am unable to reproduce this problem working with several stylesheets.

Can you attach (or send me) one of the stylesheets you are using and with which you are seeing the problem you have reported? Also, a description of the exact location where you drop the element from the structure tree (and which element that is) will help.

Thanks,
Minollo

   
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.