[XSL-LIST Mailing List Archive Home] [By Thread] [By Date] [Recent Entries] [Reply To This Message]

Re: Unwanted namespace prefix _0

Subject: Re: Unwanted namespace prefix _0
From: Martin Holmes <mholmes@xxxxxxx>
Date: Tue, 24 Dec 2013 04:58:20 -0800
Re:  Unwanted namespace prefix _0
Radu, thanks so much for clearing this up, and suggesting the workaround.

All the best for the holiday season!

Cheers,
Martin

On 13-12-24 02:40 AM, Radu Pisoi wrote:
Hi Martin,

We investigated the issue and I would like to mention that it can be
obtained only when running the transformation from oXygen.
The issue is related to the option that adds the default attributes
values when parsing an XML document with a RelaxNG schema associated.

When this option is enabled, the XML reader that it is provided by
Oxygen to the Saxon transformer does not emmit the namespace events
properly.

I will add an issue to our bug tracking tool and we'll try to resolve it
in Oxygen 15.2 which will be released at the beginning of 2014.

Meanwhile, to avoid this problem you can disable the option 'Add default
attribute values' by opening the application Options -> Preferences
dialog and selecting the 'XML / XML Parser / RELAX NG' options page.

Regards,
Radu

Radu Pisoi
<oXygen/>  XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com


On 12/23/2013 18:16, Martin Holmes wrote:
Hi all,

I'm doing an identity transform with Saxon 9.5.1.2 (HE, PE and EE all do
the same) on a TEI file with embedded examples in the Examples namespace:

<TEI xmlns="http://www.tei-c.org/ns/1.0" version="5.0">
[...]
<div>
<egXML xmlns="http://www.tei-c.org/ns/Examples" valid="true">
   For more information, consult the
   <ref target="mol:linking#linking_graphics"> guide to
   linking graphic content</ref>.</egXML>
</div>
[...]
</TEI>

In the output, Saxon generates unwanted namespace prefixes, like this:

<_0:egXML xmlns:_0="http://www.tei-c.org/ns/Examples" valid="true">
   For more information, consult the
   <_0:ref target="mol:linking#linking_graphics"> guide to
   linking graphic content</_0:ref>.</_0:egXML>

This is even though I have exclude-result-prefixes="#all", and it
happens whether or not I define a prefix in the root stylesheet element
for the Examples namespace.

What am I missing? How would I get output that looks exactly like the
input?

Cheers,
martin

Current Thread

PURCHASE STYLUS STUDIO ONLINE TODAY!

Purchasing Stylus Studio from our online shop is Easy, Secure and Value Priced!

Buy Stylus Studio Now

Download The World's Best XML IDE!

Accelerate XML development with our award-winning XML IDE - Download a free trial today!

Don't miss another message! Subscribe to this list today.
Email
First Name
Last Name
Company
Subscribe in XML format
RSS 2.0
Atom 0.3
Site Map | Privacy Policy | Terms of Use | Trademarks
Free Stylus Studio XML Training:
W3C Member
Stylus Studio® and DataDirect XQuery ™are products from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2013 All Rights Reserved.