Options - Application Settings

The first page of the Options dialog box allows you to specify general options that apply to all Stylus Studio applications.

To display the Options dialog box, select Tools > Options from the Stylus Studio menu bar.


Automatically check for externally modified files

If there are files that are part of your XML application and they are modified outside Stylus Studio while you are working on the application in Stylus Studio, Stylus Studio prompts you to indicate whether you want to update the file in Stylus Studio.

Disable check on hidden files

Hidden files are files that are in the Stylus Studio project or the Other Documents folder but not open in Stylus Studio windows. In some situations, it is useful to refresh your open files after hidden files have been updated. In other situations, doing this is unnecessary.

Automatically save modified files every nnn minutes

You can specify whether and how often you want Stylus Studio to automatically save your open files.

Automatically create backup copy (*.bak) on save

Whether or not you want Stylus Studio to create a backup copy of your documents when they are saved. Files saved to the Stylus Studio file system are saved with a * .bak extension. Backup file names for files saved to other file systems are managed by the file system. The option to create backup files is on by default.

Automatically add the Base Catalog to new projects

The Stylus Studio Base Catalog, which is bundled with every Stylus Studio installation, is a collection of over one dozen popular catalogs that conform to the OASIS catalog standard. By adding the Base Catalog to a project, any XML file in the project that are associated with files inside the catalog (a schema or DTD, for example) is validated against that catalog file.

Recent file lists

Specifies the number of files you want to display on File and Project menus. Changes to these settings take effect the next time you start Stylus Studio.

  • On File menu

The default is 4 files.

  • On Project menu

The default is 4 files.

Upon startup

Specifies the actions Stylus Studio takes when it is started:

  • Open last project

Stylus Studio automatically opens the project that was open the last time you closed Stylus Studio.

  • Open last documents

Stylus Studio automatically opens any files that were open the last time you closed Stylus Studio.

Check for newer versions

Specifies whether Stylus Studio automatically checks the Stylus Studio Web site to determine if a newer version of Stylus Studio is available. If a newer version is detected, Stylus Studio displays an animated button in its status bar. Click the button to download the new version.

  • Check for final versions
  • Check for beta versions

User interface

User interface settings for Stylus Studio:

  • Use standard MDI windows

Displays multiple documents as individual windows which you can tile, cascade, and so on.

  • Use tabbed MDI windows

Displays multiple documents as tabs that are displayed at the top of the editor window. This is the default.

  • Display Help window always on top

Whether or not to display the Stylus Studio help window on top of the Stylus Studio application.

For More Information

Specifying Stylus Studio Options

Free Stylus Studio XML Training:
W3C Member