XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Conferences Close Tree View
+ Stylus Studio Feature Requests (1192)
- Stylus Studio Technical Forum (14621)
-> - Stylus Studio - Registrar en o... (1)
-> + Stylus Studio - Registrar en o... (2)
-> + Can a pipeline send a file by ... (2)
-> + After Updateing WIN10 to WIN11... (12)
-> + Where do I add the custom java... (3)
-> + Where is the Diagram tab? (5)
-> + Applying XSLT to Word DOCX/XML (2)
-> - CSV conversion via ConvertToXM... (1)
-> + Text symbols in SS not same as... (4)
-> + Exposing xquery as webservice ... (6)
-> + Syntax Identifier (2)
-> + Saving a Converted XML as an X... (5)
-> + Output document cannot be pars... (4)
-> - Archiving output from conversi... (1)
-> + EDIFACT guideline from Stylus ... (3)
-> + CSV file putting all the data ... (5)
-> + Can't install Home version 64b... (5)
-> + presale - Can I covers this sc... (5)
-> + Problem with UNB (5)
-> + Splitting EDIFACT files pipeli... (4)
-- [1-20] [21-40] [41-60] Next
+ Website Feedback (249)
+ XSLT Help and Discussion (7625)
+ XQuery Help and Discussion (2017)
+ Stylus Studio FAQs (159)
+ Stylus Studio Code Samples & Utilities (364)
+ Stylus Studio Announcements (113)
Naresh AkhadeSubject: URIResolver error on command line
Author: Naresh Akhade
Date: 01 Apr 2010 12:53 PM

I am getting below error when i run xslt using command line options. I am using below command
java -jar d:\Naresh\saxon9he.jar -o cmd_out.xml C2JBMB09024.xml epub.xsl

Error at xsl:result-document on line 66 of epuboebgenerator.xsl:
Resolved URL is malformed: unknown protocol: d
at xsl:call-template name="create-single-html" (file:/D:/Naresh/epub-xslt/epub
at xsl:call-template name="generate-html" (file:/D:/Naresh/epub-xslt/kglml2epu
at xsl:call-template name="generate-oeb" (file:/D:/Naresh/epub-xslt/kglml2epub
Transformation failed: Run-time errors were reported

when i run same xslt in stylus it works fine and gives the proper output. I have read some threads but did not help me. I also tried with
-r URIReslover option but that didn't work..
I am using saxon9he freeware parser.
please guide me how to run the same xslt through command line also.

Thanks in advance,

Ivan PedruzziSubject: URIResolver error on command line
Author: Ivan Pedruzzi
Date: 01 Apr 2010 02:31 PM

It sounds like an invalid URL format, you are using a file path where a URL is required


Hope this helps
Ivan Pedruzzi
Stylus Studio Team

Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.