XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Conferences Close Tree View
+ Stylus Studio Feature Requests (1182)
- Stylus Studio Technical Forum (14569)
-> + EDIFACT guideline from Stylus ... (3)
-> + CSV file putting all the data ... (5)
-> + Can't install Home version 64b... (5)
-> + presale - Can I covers this sc... (5)
-> + Problem with UNB (5)
-> + Splitting EDIFACT files pipeli... (4)
-> + Problem with SAXO processor - ... (5)
-> + PDF Format Help (4)
-> + License check unreliable (2)
-> - XML related issue (1)
-> + Need help regarding pipeline o... (2)
-> + Error converting XML to EDIFAC... (4)
-> + XSLT Profiling for XSLT 1.0 s... (2)
-> + Grouping (2)
-> + Best Practice for Pipeline err... (2)
-> + pdf generation (4)
-> + Problems excuting a Pipeline w... (2)
-> + XML serializer (3)
-> + Supported EDIFACT versions (5)
-> - Anyone know XActimate ESX file... (1)
-- [1-20] [21-40] [41-60] Next
+ Website Feedback (247)
+ XSLT Help and Discussion (7617)
+ XQuery Help and Discussion (1966)
+ Stylus Studio FAQs (159)
+ Stylus Studio Code Samples & Utilities (364)
+ Stylus Studio Announcements (113)
Topic  
Postnext
Matthew FadoulSubject: Trouble using the UDDI Browser
Author: Matthew Fadoul
Date: 03 Oct 2007 09:32 PM
I was following the XML video (Web Services: Building a Web Service) as the tutorial shows a user accessing various UDDI resources (e.g. xmethods, Microsoft, IBM, and SAP). I haven't been able to successfully query these UDDI sites through the UDDI Browser UI. Some comments:

1) Instead of seeing the four options shown in the video, the UDDI browser window only lists the xmethods web address (http://uddi.xmethods.net/inquire).
2) I've attempted to search for specific services (e.g. "stock" or "weather"). I click on "search", and get zero matching results after a moment waiting.
3) I've manually entered the URLs for the other three UDDI sites. When I attempt to search them, I get zero results. I don't get any error/warning messages.

Is this a known issue? Is there a secret configuration parameter that needs to be set? I'm kinda confused. BTW, I'm not getting any kind of firewall warning, so I don't think it's a port issue.

As always, any help is appreciated.

Postnext
Ivan PedruzziSubject: Trouble using the UDDI Browser
Author: Ivan Pedruzzi
Date: 03 Oct 2007 11:21 PM
Hi Matthew,

Unfortunately most of the public UDDI registry have been shutdown,
see http://www.uddi.org/find.html

www.xmethods.net seems to be unreliable lately as well.

Hope this helps
Ivan Pedruzzi
Stylus Studio Team

Postnext
Matthew FadoulSubject: Trouble using the UDDI Browser
Author: Matthew Fadoul
Date: 04 Oct 2007 12:13 AM
Thank you for the confirmation. I guess I'm glad the problem is not on my end. :)

I also found the following article referred to by the UDDI Wikipedia entry:

http://webservices.sys-con.com/read/164624.htm

Postnext
ronny de deckerSubject: Trouble using the UDDI Browser
Author: ronny de decker
Date: 27 Mar 2008 07:09 AM
Ok I went to the site : http://www.xmethods.net

and used some wsdl : http://www.dataaccess.com/webservicesserver/textcasing.wso?WSDL

I have tried to use it in two ways :
1. I found a page where it was used , and it proved the service was running.
2. I tried from within Stylus using a scenario and Microsoft.net client

but I get an error message :
Server fails to respond


Imagenoreply.bmp
Screenshot

Posttop
(Deleted User) Subject: Trouble using the UDDI Browser
Author: (Deleted User)
Date: 27 Mar 2008 01:20 PM
Hi Ronny,
I tried the WSDL with the same arguments seen in the screenshot, and it worked on both Stylus Studio 2007 and 2008. Maybe the error was simply a temporary failure of the web server hosting the service.
Can you try again?

Alberto

   
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.