XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Oddbjørn OverskottSubject: API unlocks OK, but fails in newConvertToXML
Author: Oddbjørn Overskott
Date: 15 Jan 2007 07:32 AM
This is a bit puzzling. I call unlockAPI without problems, but when I get to creating a Converter, the following exception trace is generated, stating that the CustomFileSystem.jar, which I thought I had just called, can't be found. I have tried setting the com.stylusstudio.bindir property, but that had no effect. So what is it that is needed in StylusFileHelpers.java:533 ?

Stack trace:

[15.01.07 13:09:56:469 CET] 00000035 SystemOut O Unable to locate CustomFileSystem.jar: java.lang.NullPointerException
[15.01.07 13:09:56:469 CET] 00000035 SystemErr R java.lang.RuntimeException: Unable to create the Converter object.
at com.stylusstudio.converter.ConverterFactory.getConstructor(ConverterFactory.java:108)
at com.stylusstudio.converter.ConverterFactory.newConvertToXML(ConverterFactory.java:44)
at no.nmd.was.messagecentral.map.AbstractMap.Map(AbstractMap.java:64)
at no.nmd.was.messagecentral.map.in.OrdersD93AInMap.map(OrdersD93AInMap.java:15)
at no.nmd.was.messagecentral.MessageProcessor.run(MessageProcessor.java:69)
at java.lang.Thread.run(Thread.java:568)
Caused by: java.lang.RuntimeException: java.lang.NullPointerException
at com.exln.stylus.io.StylusFileHelpers.getBinDir(StylusFileHelpers.java:557)
at com.exln.stylus.io.StylusFileFactory.registerBuiltinSchemes(StylusFileFactory.java:148)
at com.exln.stylus.io.StylusFileLoader$ProtocolInfo.getClassLoader(StylusFileLoader.java:43)
at com.exln.stylus.io.StylusFileFactory.getAdapterClassLoader(StylusFileFactory.java:1011)
at com.stylusstudio.converter.ConverterFactory.getConstructor(ConverterFactory.java:102)
... 5 more
Caused by: java.lang.NullPointerException
at com.exln.stylus.io.StylusFileHelpers.getBinDir(StylusFileHelpers.java:533)
... 9 more

Ivan PedruzziSubject: API unlocks OK, but fails in newConvertToXML
Author: Ivan Pedruzzi
Date: 15 Jan 2007 11:33 AM
Hi Oddbjørn,

Thank You for reporting the error.

Which Stylus Studio build are you running?

Which Java Virtual Machine are you running? On which platform?

In which context are you running the Converters?
Is it a standalone application or from inside an app server?

Which converter are you trying to invoke?

What is the value of com.stylusstudio.bindir?

It would be helpful to see your Java code. If you prefer you can send a message to stylus-field-report@progress.com

Hope this helps
Ivan Pedruzzi
Stylus Studio Team

Oddbjørn OverskottSubject: API unlocks OK, but fails in newConvertToXML
Author: Oddbjørn Overskott
Date: 16 Jan 2007 09:19 AM
Originally Posted: 15 Jan 2007 04:25 PM
Sorry about my somewhat lacking error report; here are some more details:

I run 2007 Enterprise suite, build 735f. I downloaded it for evaluation / proof-of-concept on Friday, so I'm on a one week evaluation license.

The code I'm developing runs on an IBM WebSphere app server, version, and the app server uses IBM java version 1.4.2. It runs on a Windows 2000 Workstation.

com.stylusstudio.bindir is C:\Programfiler\Stylus Studio 2007 XML Enterprise Suite\bin

I am trying to invoke the EDI adapter, in order to map an edifact string to XML (and then transform it to our generic message format). The Java code is a work in progress, and as of now it looks like this:

<java fragment>
private static ConverterFactory factory = null;

public AbstractMap() {
if (factory == null) {
if (StylusFileFactory.unlockAPI("XXXXXXXXXXXX") != true) {

String eMsg = StylusFileFactory.getUnlockAPIError();
if (eMsg != null && eMsg.startsWith("Insert your")) {
logger.debug("Edit this demo program and insert your Installation ID in the call to unlockAPI");
logger.debug("Make sure CustomFileSystem.jar is in your classpath,");
logger.debug("then compile and run it again.");
else {
logger.debug("The call to StylusFileFactory.unlockAPI() failed:\n");
if (eMsg==null)
logger.debug("No reason for failure was returned.");
else logger.debug(eMsg);
else {
logger.debug("StylusFileFactory was unlocked ok.");
factory = ConverterFactory.newInstance();

protected GenericMessage Map(String messageString) {
try {
StringWriter sw = new StringWriter();
StreamSource input = new StreamSource(new StringReader(messageString));
StreamResult output = new StreamResult(sw);
Converter conv = factory.newConvertToXML("adapter:EDI:decode=no:tbl=no:typ=no:opt=yes");
conv.convert(input, output);
catch (ConverterException ex) {
logger.error("Converter error: ", ex);
return null;
</java fragment>

The calling function creates a subtype of AbstractMap, and then calls the map() function.

Oddbjørn OverskottSubject: API unlocks OK, but fails in newConvertToXML
Author: Oddbjørn Overskott
Date: 16 Jan 2007 04:06 AM
Problem solved: It was the com.stylusstudio.bindir property that wasn't set in the right way. Once I corrected it, this problem went away.

Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.