XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Conferences Close Tree View
+ Stylus Studio Feature Requests (1182)
- Stylus Studio Technical Forum (14569)
-> + EDIFACT guideline from Stylus ... (3)
-> + CSV file putting all the data ... (5)
-> + Can't install Home version 64b... (5)
-> + presale - Can I covers this sc... (5)
-> + Problem with UNB (5)
-> + Splitting EDIFACT files pipeli... (4)
-> + Problem with SAXO processor - ... (5)
-> + PDF Format Help (4)
-> + License check unreliable (2)
-> - XML related issue (1)
-> + Need help regarding pipeline o... (2)
-> + Error converting XML to EDIFAC... (4)
-> + XSLT Profiling for XSLT 1.0 s... (2)
-> + Grouping (2)
-> + Best Practice for Pipeline err... (2)
-> + pdf generation (4)
-> + Problems excuting a Pipeline w... (2)
-> + XML serializer (3)
-> + Supported EDIFACT versions (5)
-> - Anyone know XActimate ESX file... (1)
-- [1-20] [21-40] [41-60] Next
+ Website Feedback (247)
+ XSLT Help and Discussion (7617)
+ XQuery Help and Discussion (1966)
+ Stylus Studio FAQs (159)
+ Stylus Studio Code Samples & Utilities (364)
+ Stylus Studio Announcements (113)
Topic  
Postnext
David HarrisSubject: Empty Columns Not Seen when Using the XQuery Mapper
Author: David Harris
Date: 19 Jul 2006 03:32 PM
When using the XQuery Mapping feature to an Oracle data source, only columns in the database which have values appear in the mapper on the left; empty columns don't appear. Is there a way to see all columns, regardless of whether they have a value or not in the database?

Postnext
Ivan PedruzziSubject: Empty Columns Not Seen when Using the XQuery Mapper
Author: Ivan Pedruzzi
Date: 19 Jul 2006 04:59 PM
Hi David,

Which Stylus Studio version are you running?

How you access Oracle, via .rdbxml or using the collection function?


Thank You
Ivan Pedruzzi
Stylus Studio Team

Postnext
Ivan PedruzziSubject: Empty Columns Not Seen when Using the XQuery Mapper
Author: Ivan Pedruzzi
Date: 19 Jul 2006 05:41 PM
The Stylus Studio 2006 R3 uses the database schema to populate the tree in the mapping tool.

you can try the latest version side by side
http://www.stylusstudio.com/xml_download.html

Hope this helps
Ivan Pedruzzi
Stylus Studio Team

Postnext
David HarrisSubject: Empty Columns Not Seen when Using the XQuery Mapper
Author: David Harris
Date: 20 Jul 2006 03:07 PM
For a number of reasons, we can't switch our version now. We're using Build 501h of the Enterprise Edition. Should this work in this Build or was there a fix?

Postnext
David HarrisSubject: Empty Columns Not Seen when Using the XQuery Mapper
Author: David Harris
Date: 20 Jul 2006 03:06 PM
Collection function is the only option we're seeing. We're using Build 501h of the Enterprise Edition.

Posttop
Ivan PedruzziSubject: Empty Columns Not Seen when Using the XQuery Mapper
Author: Ivan Pedruzzi
Date: 20 Jul 2006 06:47 PM
Hi David,

Unfortunately the mapping tool in build 501 uses the table data to populate the tree.

To workaround the problem you could create a simple XML document that reproduces the table structure then use the document for design the the query using mapper, when you are done you can replace the call to the document function with a call to collection. Be sure to have the collection defined in the scemario dialog and to run your query with the DataDirect XQuery processor.


Hope this helps
Ivan Pedruzzi
Stylus Studio Team

   
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.