XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Conferences Close Tree View
+ Stylus Studio Feature Requests (1188)
- Stylus Studio Technical Forum (14584)
-> + Exposing xquery as webservice ... (2)
-> + Syntax Identifier (2)
-> + Saving a Converted XML as an X... (5)
-> + Output document cannot be pars... (4)
-> - Archiving output from conversi... (1)
-> + EDIFACT guideline from Stylus ... (3)
-> + CSV file putting all the data ... (5)
-> + Can't install Home version 64b... (5)
-> + presale - Can I covers this sc... (5)
-> + Problem with UNB (5)
-> + Splitting EDIFACT files pipeli... (4)
-> + Problem with SAXO processor - ... (5)
-> + PDF Format Help (4)
-> + License check unreliable (2)
-> - XML related issue (1)
-> + Need help regarding pipeline o... (2)
-> + Error converting XML to EDIFAC... (4)
-> + XSLT Profiling for XSLT 1.0 s... (2)
-> + Grouping (2)
-> + Best Practice for Pipeline err... (2)
-- [1-20] [21-40] [41-60] Next
+ Website Feedback (247)
+ XSLT Help and Discussion (7617)
+ XQuery Help and Discussion (1971)
+ Stylus Studio FAQs (159)
+ Stylus Studio Code Samples & Utilities (364)
+ Stylus Studio Announcements (113)
Topic  
Postnext
dean katzSubject: Date Format error
Author: dean katz
Date: 29 Sep 2005 02:37 PM
Originally Posted: 29 Sep 2005 02:35 PM
When I run this statement in StylusStudio<br> <br> SELECT<br> XMLELEMENT( NAME "client",<br> XMLATTRIBUTES(t.record_id, t.system_id, t.odbid, t.date_added, t.date_updated),<br> XMLELEMENT( NAME "first_name", t.first_name),<br> XMLELEMENT( NAME "last_name", t.last_name),<br> XMLELEMENT( NAME "mi_initial", t.mi_initial),<br> XMLELEMENT( NAME "soc_sec_no", t.soc_sec_no),<br> XMLELEMENT( NAME "dynamic_content", XMLELEMENT( NAME "svpprofgender", t.svpprofgender),<br> XMLELEMENT( NAME "svpprofdob",t.svpprofdob), XMLELEMENT( NAME "svpprofrace",t.svpprofrace)))<br> FROM myServicePoint.DBO.mytblrawclients t<br> WHERE clientndx = 1500<br> <br> I get this result:<br> <client record_id='RID1500' system_id='SID1500' odbid='346' date_added='2001-08-09 00:00:00.0' date_updated='2001-08-09 00:00:00.0'><first_name>TERROS</first_name><last_name>DILWORTH</last_name><mi_initial></mi_initial><soc_sec_no>319-01-1874</soc_sec_no><dynamic_content><svpprofgender>m</svpprofgender><svpprofdob>1993-11-06 00:00:00.0</svpprofdob><svpprofrace>White/Caucasian</svpprofrace></dynamic_content></client><br> <br> I.E. the date_added is missing a 'T' (instead of '2001-08-09T00:00:00.0') in the middle so that it won't get validated against the schema. How can fix this error?

Posttop
Ivan PedruzziSubject: Date Format error
Author: Ivan Pedruzzi
Date: 30 Sep 2005 08:34 AM
Hi Dean

To force the datetime format to ISO8601 you have to prepend the following comment to your query.

/*{jxtr-hints timestamp_encoding=iso8601*/


Hope this helps
Ivan Pedruzzi
Stylus Studio Team

   
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.