XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Conferences Close Tree View
+ Stylus Studio Feature Requests (1168)
- Stylus Studio Technical Forum (14416)
-> + Unable to auto detect JRE in X... (2)
-> - Unable to auto detect JRE in X... (1)
-> - where to find information (1)
-> + X16 - XPath 3.0, XQuery 3.0, X... (2)
-> - Test (1)
-> - XSLT debugger shows [symbol u... (2)
-> ->XSLT debugger shows [sym...
-> - How do i use *.conv to process... (1)
-> - How do i use *.conv to process... (1)
-> + Not able to configure JVM in ... (5)
-> + Converting Cobol flat file to ... (2)
-> + Problem with uninstall - Windo... (2)
-> + Function current() is not reco... (6)
-> + API or web version (2)
-> + How to use Saxon for X16 on WI... (9)
-> + Error in SS X14 syntax highlig... (2)
-> + Option not available (2)
-> + XML Diff functionality and sor... (3)
-> + Convert Oagis XML file to TXT (4)
-> + DataDirect xqresultsequence is... (2)
-> - xfile Legacy file format suppo... (1)
-- [1-20] [21-40] [41-60] Next
+ Website Feedback (244)
+ XSLT Help and Discussion (7593)
+ XQuery Help and Discussion (1941)
+ Stylus Studio FAQs (159)
+ Stylus Studio Code Samples & Utilities (363)
+ Stylus Studio Announcements (113)
Topic  
Postnext
Yitzhak KhabinskySubject: XSLT debugger shows [symbol unknown] for variable values
Author: Yitzhak Khabinsky
Date: 27 Feb 2018 09:29 PM
Originally Posted: 27 Feb 2018 09:03 PM
I am using SS Enterprise X16, latest build 1987o 64-bit edition.

Unfortunately, I am having 2 issues with the XSLT debugger for Saxon:
- debugger shows <symbol unknown> for variables instead of actual values.
- local variables disappear from the debugger's variable pane.

When I switch the processor from the Saxon to the .NET XslTransform in the scenario, the XSLT debugger is working without any problem.

Please advise.


Documentwinkimjr2.xslt


Documentwinkimjr2.xml

Posttop
Ivan PedruzziSubject: XSLT debugger shows [symbol unknown] for variable values
Author: Ivan Pedruzzi
Date: 05 Mar 2018 10:59 PM
Yitzhak

Stylus Studio does execute Saxon in "debug mode" but optimization still occur, variables can be replaced with values and function calls can get in-lined.

We will investigate if we can further tune the behavior on our side

Hope this helps
Ivan Pedruzzi
Stylus Studio Team

   
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.