XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Conferences Close Tree View
+ Stylus Studio Feature Requests (1192)
+ Stylus Studio Technical Forum (14621)
+ Website Feedback (249)
- XSLT Help and Discussion (7625)
-> + Use of before and after string (3) Sticky Topic
-> - How do I substitute element ty... (1)
-> + How does one add working days ... (4)
-> - Help, I have existing XLT and... (1)
-> + Need help on XSLT issue - (2)
-> + EDI to XML Conversion (7)
-> - XML To JSON Conversion using X... (1)
-> + Formatting Paragraphs to same ... (2)
-> - Grouping of records (1)
-> - Problems with xsd 1.1 (4)
-> ->Problems with xsd 1.1
-> ->Problems with xsd 1.1
-> ->Problems with xsd 1.1
-> + XML to HL7 mapping (3)
-> + XSLT 3 and Iterate (2)
-> + XSL-FO to PDF preview (3)
-> + java.lang.RuntimeException: Er... (2)
-> + Create Acroforms with Stylus X... (2)
-> + How to change XSLT parameter s... (3)
-> + how to change format of the da... (2)
-> + Search "Next 8 Results " doesn... (2)
-> - Support for Git (1)
-> + newbee (8)
-- [1-20] [21-40] [41-60] Next
+ XQuery Help and Discussion (2017)
+ Stylus Studio FAQs (159)
+ Stylus Studio Code Samples & Utilities (364)
+ Stylus Studio Announcements (113)
(Deleted User) Subject: Problems with xsd 1.1
Author: (Deleted User)
Date: 22 Nov 2019 02:45 PM
Originally Posted: 22 Nov 2019 02:44 PM

I am having a bit of problems with Stylus Studio (SS) when trying to use a xsd version 1.1.

Getting this error:

invalid element 'assert' in complex type definition.

I have tried to use different validation engines, but I get an error whatever I choose.

Attached a simple example xsd that fails.

Can anyone help me out regarding what I am doing wrong.

SS version is X16 build 1987o.

xsd sample problem

Ivan PedruzziSubject: Problems with xsd 1.1
Author: Ivan Pedruzzi
Date: 22 Nov 2019 03:33 PM
Originally Posted: 22 Nov 2019 03:32 PM
Saxon schema processor seems to work quite well, see screenshots attached

Ivan Pedruzzi
Stylus Studio Team

(Deleted User) Subject: Problems with xsd 1.1
Author: (Deleted User)
Date: 25 Nov 2019 08:41 AM
Originally Posted: 25 Nov 2019 08:12 AM
Hi Ivan.
I found why I was experiencing problems. The validator falls back to the default validator every time, I need to specify the xsd 1.1 everytime I validate, the IDE does not remember the last setting.

Also when validating the XML files.
Maybe this feature could be included in a future relaese?

Another problem related to this is how do I run this validation in a Pipeline? I cannot find a validator in the pipeline server that supports xsd 1.1, I continue to get this error: Assertions require XSD 1.1 to be enabled

Thanks for your input.

Ivan PedruzziSubject: Problems with xsd 1.1
Author: Ivan Pedruzzi
Date: 25 Nov 2019 02:22 PM

The button is not a drop-down, clicking on the popup menu does not change the button state.Clicking on the icon always invokes the built-in schema processor.

Hope this helps
Ivan Pedruzzi
Stylus Studio Team

Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.