XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Postnext
Tom HebbronSubject: link element not closed in v4 beta
Author: Tom Hebbron
Date: 09 Apr 2002 10:29 AM
Hi,

First of all - thank you VERY much for finally allowing xalan to be used for debugging stylesheets - as almost every peice of xsl i develop has to sit in a system under xalan, it is very useful to be able to debug in this environment.

OK, so the problem. I have a stylesheet to build RSS feeds for a web site - if uses a java extension to build a dynamic node set of filenames to be processed, and then a for-each loop to load that document() and extract some meta-data for the RSS feed. My problem is that link tags are being left open  -  is expressed in the output as 'some URI' but no closing  tag
This must be something to do with stylus, as running the same xslt under xalan externally to stylus gives coreect output.

Posttop
Ivan PedruzziSubject: RE: link element not closed in v4 beta
Author: Ivan Pedruzzi
Date: 09 Apr 2002 01:51 PM
Hi Tom,

HTML specs defined the "link" element with empty content
http://www.w3.org/TR/html4/struct/links.html#edef-LINK
You should change your style sheet in this way:


If you want to preserve the "link" element change the style sheet's
output to XML

Hope this helps.

Ivan Pedruzzi
eXcelon Corporation
http://www.stylusstudio.com



> -----Original Message-----
> From: stylus-studio-tech Listmanager [mailto:listmanager]
> Sent: Tuesday, April 09, 2002 10:41 AM
> To: Recipients of 'stylus-studio-tech' suppressed
> Subject: link element not closed in v4 beta
>
>
> From: "Tom Hebbron"
>
>
> Hi,
>
> First of all - thank you VERY much for finally allowing xalan
> to be used for debugging stylesheets - as almost every peice
> of xsl i develop has to sit in a system under xalan, it is
> very useful to be able to debug in this environment.
>
> OK, so the problem. I have a stylesheet to build RSS feeds
> for a web site - if uses a java extension to build a dynamic
> node set of filenames to be processed, and then a for-each
> loop to load that document() and extract some meta-data for
> the RSS feed. My problem is that link tags are being left
> open - is
> expressed in the output as 'some URI' but no closing
> tag This must be something to do with stylus, as
> running the same xslt under xalan externally to stylus gives
> coreect output.
>
>
>
> To reply: mailto:stylus-studio-tech.4941@edn.exceloncorp.com
> To start a new topic: mailto:stylus-studio-tech@edn.exceloncorp.com
> To login: http://edn.exceloncorp.com/~SSDN
>
>

 
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2011 All Rights Reserved.