XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Postnext
Troy HewittSubject: Mapper loses connections
Author: Troy Hewitt
Date: 07 Feb 2002 06:40 PM
Stylus Studio 3.1.069k:

After mapping several (3) Source fields thru the Multiply function to the Format-Number function and then to the Target field, the center graph map does the following:

1) Several function icons don't float when the source tree is scrolled.

2) After closing the tree and re-opening, the center graph has lost 2 of 3 the mapping lines as well as the function icons.

3) Drawing an additional line from a function to an 'already mapped' target field doesn't produce an error.

Troy

Postnext
Minollo I.Subject: Re: Mapper loses connections
Author: Minollo I.
Date: 07 Feb 2002 07:31 PM
Can you send us a testcase for this?
Thanks,
Minollo

Postnext
Minollo I.Subject: Re: Mapper loses connections
Author: Minollo I.
Date: 07 Feb 2002 07:33 PM
BTW, this might be related to the format-number issue addressed in 69l;
anyway, a testcase will surely help.

Minollo

Postnext
(Deleted User) Subject: RE: Mapper loses connections
Author: (Deleted User)
Date: 07 Feb 2002 08:05 PM
Troy, Thanks for your feedback. please see my answers below:


> 1) Several function icons don't float when the source tree is
scrolled.
Function icons in the middle pane is designed not to scroll. It
is hard to come up with a good way to scroll the middle pane while you
scroll one of the schema tree...

>
> 2) After closing the tree and re-opening, the center graph has lost 2
of 3
> the mapping lines as well as the function icons.

We can't reproduce this after we fix a format-number related problem in
our internal build, but we will take a closer look after we receive your
example.

>
> 3) Drawing an additional line from a function to an 'already mapped'
> target field doesn't produce an error.
>
Drawing an additional line from a function to an 'already mapped'
target is not an error. It means the value of this target will be the
combination of the two source or user want to create a duplicate target
node...this is why you will see a context menu when you drag a line to a
already mapped target...Many users need this feature..


Hope this help...

Song Wang

Posttop
Troy HewittSubject: RE: Mapper loses connections
Author: Troy Hewitt
Date: 07 Feb 2002 08:24 PM
Thanks Song.

I believe it is related to the format-number() issue. I remapped the document using only Multiply and the issue went away.

Regarding the scrolling: When I initially built the map (just a few fields) one of the function icons DID scroll - maybe it was a fluke. This makes the working area much more clear. If I have 20, 30, 40, or 50 mappings ALL tied to one or more functions, no scrolling means my screen will be PACKED with icons and virtually unreadable. I have one client with 270 field mappings.

An algorithm that simply checks if the source or target field is on the screen would help to identify whether the icon should be displayed (just a thought).

Thanks,

Troy

 
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2011 All Rights Reserved.