[XSL-LIST Mailing List Archive Home] [By Thread] [By Date] [Recent Entries] [Reply To This Message]

Re: Looking Not Working for No Obvious Reason

Subject: Re: Looking Not Working for No Obvious Reason
From: "Eliot Kimber" <ekimber@xxxxxxxxxxxxxxxxxxx>
Date: Thu, 21 Jun 2007 08:06:04 -0500
Re:  Looking Not Working for No Obvious Reason
David Carlisle wrote:

> Input data is:.. saved as ek.xml

 > The corresponding mapping entry is:
I commented out that entry from your original post and replaced it with
that (just in case there was a weird difference somewhere), and the
function you posted worked for me, see below.

As I suspected, it was my own bug. I was applying a normalization function to my lookup string before doing the lookup, which for reasons that are still unclear to me, was producing strings, in most cases, that did not match the keys in the table. Removing the normalization fixed the problem.


Cheers,

Eliot

--
W. Eliot Kimber
Professional Services
Innodata Isogen
8500 N. Mopac, Suite 402
Austin, TX 78759
(214) 954-5198

ekimber@xxxxxxxxxxxxxxxxxxx
www.innodata-isogen.com

Current Thread

PURCHASE STYLUS STUDIO ONLINE TODAY!

Purchasing Stylus Studio from our online shop is Easy, Secure and Value Priced!

Buy Stylus Studio Now

Download The World's Best XML IDE!

Accelerate XML development with our award-winning XML IDE - Download a free trial today!

Don't miss another message! Subscribe to this list today.
Email
First Name
Last Name
Company
Subscribe in XML format
RSS 2.0
Atom 0.3
Site Map | Privacy Policy | Terms of Use | Trademarks
Free Stylus Studio XML Training:
W3C Member
Stylus Studio® and DataDirect XQuery ™are products from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2013 All Rights Reserved.