RE: Re: XPath/XSLT 2.0: What is the most efficient way
> > Thank you, Mike. > > The name "exists" does not describe very well what the > function actually does. A far-better name is "non-empty", and > it is immediately perceived as the really complementary > function to empty(). > Actually, my thinking was the opposite. I think the meaning of exists(@a) is fairly intuitive, whereas the meaning of empty(@a) is not. But this just proves that choosing names that will enable people to guess correctly what the function does is never easy. Michael Kay XSL-List info and archive: http://www.mulberrytech.com/xsl/xsl-list
PURCHASE STYLUS STUDIO ONLINE TODAY!
Purchasing Stylus Studio from our online shop is Easy, Secure and Value Priced!
Download The World's Best XML IDE!
Accelerate XML development with our award-winning XML IDE - Download a free trial today!
Subscribe in XML format