XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Postnext
Tracey ZellmannSubject: validating a 4.01 transitional html page
Author: Tracey Zellmann
Date: 15 Sep 2008 12:02 PM
I have a 4.01 transitional html page in stylus studio and I am trying to validate it, using XML -> Validate Document from the menu bar. Here is my DOCTYPE

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

However, Stylus Studio seems to go to that dtd and then complain that it is invalid

http://www.w3.org/TR/html4/loose.dtd:31,3: FATAL ERROR: Unterminated entity declaration, 'HTML.Version'

How can I get around this problem ?

Posttop
Alberto MassariSubject: validating a 4.01 transitional html page
Author: Alberto Massari
Date: 15 Sep 2008 12:26 PM
Hi Tracey,
unfortunately the loose.dtd has been written using the SGML syntax for DTD, that allows comments inside declarations using the "--" syntax. So, that DTD is not a valid one according to XML, and shouldn't be used for such a purpose (you should turn to XHTML DTDs).

Hope this helps,
Alberto

 
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.