XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Conferences Close Tree View
+ Stylus Studio Feature Requests (1168)
- Stylus Studio Technical Forum (14388)
-> + API or web version (2)
-> + How to use Saxon for X16 on WI... (7)
-> + Error in SS X14 syntax highlig... (2)
-> + Option not available (2)
-> + XML Diff functionality and sor... (3)
-> + Convert Oagis XML file to TXT (4)
-> + DataDirect xqresultsequence is... (2)
-> - xfile Legacy file format suppo... (1)
-> + TPFDF (3)
-> + Help needed with SLSRPT - EDIF... (2)
-> - keeps crashing after I try and... (1)
-> + Can SS do this? (14)
-> - CargoImp support (1)
-> + No Preview Displayed - File is... (3)
-> - Stylus Studio X16 build 1974l ... (1)
-> + Help! Help!Help! Regading form... (2)
-> + FileNotFoundException generati... (6)
-> + FO External Graphic Producing ... (2)
-> + Use of Java methodes (4)
-> + get generated XQuery output on... (2)
-- [1-20] [21-40] [41-60] Next
+ Website Feedback (244)
+ XSLT Help and Discussion (7583)
+ XQuery Help and Discussion (1941)
+ Stylus Studio FAQs (159)
+ Stylus Studio Code Samples & Utilities (363)
+ Stylus Studio Announcements (113)
Topic  
Postnext
Chris HillSubject: Provider org.apache.xerces.jaxp.SAXParserFactoryImpl not found
Author: Chris Hill
Date: 23 Jul 2008 02:13 PM
I am running an XSLT against a XML file with a processor type of ".NET XslCompiledTraonsform". At first it was complaining about JVM being missing so I installed the latest java. Now I'm getting this error...

javax.xml.transform.TransformerConfigurationException:
javax.xml.transform.TransformerException: org.xml.sax.SAXException:
javax.xml.parsers.FactoryConfigurationError: Provider org.apache.xerces.jaxp.SAXParserFactoryImpl not found

I searched these forums and found two other examples of this kind of an error. One topic was about SaxonJ and the other had to do with the Classpath being wrong. I have looked into both of those but they do not seem to relate to my error.

Postnext
Tony LavinioSubject: Provider org.apache.xerces.jaxp.SAXParserFactoryImpl not found
Author: Tony Lavinio
Date: 23 Jul 2008 05:08 PM
It's unclear exactly what you are doing, because the .Net
CompiledTransform doesn't require Java. The Xerces engine
however does, and that relates to the errors you are seeing.

Can you check the scenario properties of your XSLT to see if in fact
you are using the engine you think you are?

Posttop
Chris HillSubject: Provider org.apache.xerces.jaxp.SAXParserFactoryImpl not found
Author: Chris Hill
Date: 23 Jul 2008 05:41 PM
Thank you for your quick reply. I checked the scenario and the processor tab has ".NET XslCompiledTransform" set for the processor. The rest of the options in there appear to be blank or unchecked. The Source XML URL is a local file, "file:///c:/test.xml".

I tried changing the processor to "Built-In" and then got an error on the VB.NET code at the top. "Error: 'Invalid class string;". I tried ".NET XslTransform" and that seems to have worked. The error went away and the resulting transformed data appears to be correct. We are using compiled transforms in our code so i'd really prefer to get that processor type working... but if we have to we could make due with the ".NET XslTransform" processor.

   
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.