XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 Go to previous topicPrev TopicGo to next topicNext Topic
Postnext
Jon GallegosSubject: Node already has a control link
Author: Jon Gallegos
Date: 28 Apr 2008 03:20 PM
Originally Posted: 28 Apr 2008 02:23 PM
The following code is giving me an error

Node 'Form/UserData/UserValue/@title' already has a control link

I have no clue as to what this means or how to resolve this problem.


<Form id="{count(preceding-sibling::*)*30+5}">
<xsl:attribute name="name">
<xsl:value-of select="ns1:part/ns1:partName"/>
</xsl:attribute>
<xsl:attribute name="subType">CRF Form</xsl:attribute>
<xsl:attribute name="subClass">H_crfclass_2</xsl:attribute>
<UserData id="{count(preceding-sibling::*)*30+6}" type="FormAttributes">
<UserValue title="H_model">
<xsl:attribute name="value">
<xsl:value-of select="ns1:family"/>
</xsl:attribute>
</UserValue>
<UserValue title="H_crfdatabasenumber">
<xsl:attribute name="value">
<xsl:value-of select="ns1:problem/ns1:problemXvlLink"/>
</xsl:attribute>
</UserValue>
<UserValue>
<xsl:choose>
<xsl:when test="ns1:factory = 'PUR'">
<xsl:attribute name="title">
<xsl:value-of select="'H_supplier'"/>
</xsl:attribute>
</xsl:when>
<xsl:otherwise>
<xsl:attribute name="title">
<xsl:value-of select="'H_requestingplant'"/>
</xsl:attribute>
</xsl:otherwise>
</xsl:choose>
<xsl:attribute name="value">
<xsl:value-of select="ns1:factory"/>
</xsl:attribute>
</UserValue>
<xsl:if test="ns1:workflow/ns1:wfStatus != ' '">
<UserValue title="H_wfHaneiTuchiNo">
<UserList id="{count(preceding-sibling::*)*30+28}" type="list">
<xsl:for-each select="ns1:workflow">
<Item>
<xsl:attribute name="value">
<xsl:value-of select="ns1:wfHaneiTuchiNo"/>
</xsl:attribute>
</Item>
</xsl:for-each>
</UserList>
</UserValue>
</xsl:if>
</UserData>
</Form>

Posttop
Alberto MassariSubject: Node already has a control link
Author: Alberto Massari
Date: 29 Apr 2008 06:19 AM
Hi Jon,
the error is caused by the presence of two xsl:attribute building the same attribute under the same element; you should replace that fragment with this one

<UserValue>
<xsl:attribute name="title">
<xsl:choose>
<xsl:when test="ns1:factory = 'PUR'">
<xsl:value-of select="'H_supplier'"/>
</xsl:when>
<xsl:otherwise>
<xsl:value-of select="'H_requestingplant'"/>
</xsl:otherwise>
</xsl:choose>
</xsl:attribute>


Hope this helps,
Alberto

 
Topic Page 1 2 3 4 5 6 7 8 9 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.