XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Conferences Close Tree View
+ Stylus Studio Feature Requests (1168)
- Stylus Studio Technical Forum (14388)
-> + API or web version (2)
-> + How to use Saxon for X16 on WI... (7)
-> + Error in SS X14 syntax highlig... (2)
-> + Option not available (2)
-> + XML Diff functionality and sor... (3)
-> + Convert Oagis XML file to TXT (4)
-> + DataDirect xqresultsequence is... (2)
-> - xfile Legacy file format suppo... (1)
-> + TPFDF (3)
-> + Help needed with SLSRPT - EDIF... (2)
-> - keeps crashing after I try and... (1)
-> + Can SS do this? (14)
-> - CargoImp support (1)
-> + No Preview Displayed - File is... (3)
-> - Stylus Studio X16 build 1974l ... (1)
-> + Help! Help!Help! Regading form... (2)
-> + FileNotFoundException generati... (6)
-> + FO External Graphic Producing ... (2)
-> + Use of Java methodes (4)
-> + get generated XQuery output on... (2)
-- [1-20] [21-40] [41-60] Next
+ Website Feedback (244)
+ XSLT Help and Discussion (7583)
+ XQuery Help and Discussion (1941)
+ Stylus Studio FAQs (159)
+ Stylus Studio Code Samples & Utilities (363)
+ Stylus Studio Announcements (113)
Topic  
Postnext
Dominik SadowskiSubject: 2007 R2 saxon 8.9 debug problem
Author: Dominik Sadowski
Date: 07 May 2007 03:13 AM
Hi
There is a problem with xsl 2.0 debugging using saxon 8.9.0.3.
Debugging windows doesn't show informations such as [Contex] in Variables window. Watch window not working too (watch attached screenshoot)

It works properly with saxon 8.9.0.3 only when stylesheet version="1.0"
or when it is set to v 2.0 but global variables/parameters removed.

In pervous release of Stylus Studio, with older saxon those problems doesn't exist.

I was debugging with breakpoint created at main template "/" : <xsl:template match="/">

try to debug that xslt (modified ver. from Stylus Studio examples sampleBooksToCatalog.xsl):

<?xml version="1.0" ?>

<xsl:stylesheet version="2.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:output method="xml" version="1.0" encoding="UTF-8" indent="yes"/>

<xsl:variable name="str"><xsl:text> sample string</xsl:text></xsl:variable>

<xsl:template match="/">
<Catalog>
<Book>
<xsl:for-each select="books/book/title">
<Title>
<xsl:value-of select="."/>
<xsl:value-of select="$str"/>
</Title>
</xsl:for-each>
</Book>
</Catalog>
</xsl:template>
</xsl:stylesheet>


Imagedebugproblem.JPG

Posttop
Alberto MassariSubject: 2007 R2 saxon 8.9 debug problem
Author: Alberto Massari
Date: 07 May 2007 12:46 PM
Hi Dominic,
we can reproduce the problem here; we'll investigate the causes for this regression, and let you know.

Thanks for reporting the problem,
Alberto

   
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.