XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Postnext
(Deleted User) Subject: senseX on xml file with own schema
Author: (Deleted User)
Date: 19 Jan 2004 04:14 AM
Hi,
how do I get senseX to work with my files associated with my schema files. I am sure this use to work by associating a schema file and then just saving the xml file.

Thanks

Postnext
Alberto MassariSubject: Re: senseX on xml file with own schema
Author: Alberto Massari
Date: 19 Jan 2004 10:21 AM
Hi Martin,

At 04.40 19/01/2004 -0500, stylus-studio-tech Listmanager wrote:
>From: "Martin Roberts"
>
>Hi,
> how do I get senseX to work with my files associated with my schema
> files. I am sure this use to work by associating a schema file and then
> just saving the xml file.

SenseX reads the schema associated to an XML document when it is loaded
and, after that, every X seconds (with X set in the Tools | Options | XML
Settings), so it could be you raised that number (by default set to 10
seconds) and you didn't wait enough time. You can see when this happens
because the color for the XML tags changes from yellow to purple.
When editing an XML Schema document, though, the schema is read just once,
when the document is loaded.

Keep in mind that the schema loading could be failing because of errors in
the schema itself.

If you still don't see the SenseX popup after checking these settings, you
should provide us with a testcase.

Hope this helps,
Alberto

Postnext
(Deleted User) Subject: Re: senseX on xml file with own schema
Author: (Deleted User)
Date: 01 Mar 2004 07:48 AM
For SenseX to work does my XMl file have to validate first?

Postnext
(Deleted User) Subject: Re: senseX on xml file with own schema
Author: (Deleted User)
Date: 01 Mar 2004 07:52 AM
SenseX does not seem to work with prefixed items. If I have element
it works if I associate a prefix in the xmlns statement it does not so adding xmlns:as="" to the namespace stops senseX working

Postnext
Alberto MassariSubject: Re: senseX on xml file with own schema
Author: Alberto Massari
Date: 01 Mar 2004 08:18 AM
At 08.18 01/03/2004 -0500, stylus-studio-tech Listmanager wrote:
>From: "Martin Roberts"
>
>SenseX does not seem to work with prefixed items. If I have element
> it works if I associate a prefix in the xmlns statement it does not
>so adding xmlns:as="" to the namespace stops senseX working

Hi Martin,
can you send me an example (XML+XSD) that shows this behavior? Sense:X
should work on any prefix (if the XSD file is valid).

Alberto

Postnext
(Deleted User) Subject: Re: senseX on xml file with own schema
Author: (Deleted User)
Date: 01 Mar 2004 10:32 AM
Alberto,

I have noticed two bahviours that seem odd.
1) if I have a namespace with prefix the senseX does not work. This however is overcome when you remove prefixes from elements without removing the prefix ref from the xmlns.
2) attaching the schema does not link successfully with the xmlns definitions. If you have anonymous elements(no prefixes) and a namespace declaration of xmlns:as="ns" and then attach a schema which has an element defined that matches the root node, the senseX works even though the namespaces do not match.

Can you confirm that senseX is namespace savvy. By this I mean that it understands and works with namespace prefixes and targetnamespaces?
For example can it handle two attached schemas?

Thanks


ApplicationCAMv1.0Candidate.xsd
Schema File

ApplicationCAM1_0_Candidate.cam
XMl file - note xmlns:as and namespaces

Posttop
Alberto MassariSubject: Re: senseX on xml file with own schema
Author: Alberto Massari
Date: 01 Mar 2004 04:22 PM
Hi Martin,

At 10.58 01/03/2004 -0500, stylus-studio-tech Listmanager wrote:
>From: "Martin Roberts"
>
>Alberto,
>
>I have noticed two bahviours that seem odd.
>1) if I have a namespace with prefix the senseX does not work. This
>however is overcome when you remove prefixes from elements without
>removing the prefix ref from the xmlns.
>2) attaching the schema does not link successfully with the xmlns
>definitions. If you have anonymous elements(no prefixes) and a namespace
>declaration of xmlns:as="ns" and then attach a schema which has an element
>defined that matches the root node, the senseX works even though the
>namespaces do not match.
>
>Can you confirm that senseX is namespace savvy. By this I mean that it
>understands and works with namespace prefixes and targetnamespaces?
>For example can it handle two attached schemas?

I can see what you are describing in the sample schema; this is because
Sense:X currently will build a list of prefix-less names from the imported
schema. We will change this to reflect the actual prefix declared in the
root element (this means that in your example, the "cam" prefix will need
to be correctly assigned in the root element, instead of being declared in
the middle of the document).

Thanks for reporting this,
Alberto

 
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.