XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Postnext
David ReesSubject: watch doesn't work with variables (100g)
Author: David Rees
Date: 10 Oct 2002 04:15 PM
Watch doesn't seem to work with variables as described. I don't see any values for any xpath expression that uses variables. This happens for built-in or the internal Xalanj. I've attached a screenshot.

thanks,

dave


Imagescreen1.jpg
screenshot

Postnext
David ReesSubject: watch doesn't work with variables (100g)
Author: David Rees
Date: 10 Oct 2002 04:43 PM
This seems to be fixed in 100k (I was using 100h). I hadn't realized there was a newer beta version because the "check for newest beta" was not reporting it.

thanks,

d

On 10/10/02 4:15:36 PM, David Rees wrote:
>Watch doesn't seem to work
>with variables as described. I
>don't see any values for any
>xpath expression that uses
>variables. This happens for
>built-in or the internal
>Xalanj. I've attached a
>screenshot.
>
>thanks,
>
>dave



Postnext
Minollo I.Subject: Re: watch doesn't work with variables (100g)
Author: Minollo I.
Date: 10 Oct 2002 05:16 PM
Build updates don't trigger the new version available communication; we did
that originally to avoid noise, but we should probably revise this policy.

Anyway, 100k may have addressed issues in the XalanJ/Saxon space, but not
in the internal processor. In any case, what Ivan suggested still stands.
If you type $myVar, the watch window will display the value of the myVar
variable. If you type myVar, the watch window will display the result of
the 'myVar' XPath expression in the current context, which in most cases
won't be what you would expect.

Minollo

Postnext
Ivan PedruzziSubject: RE: watch doesn't work with variables (100g)
Author: Ivan Pedruzzi
Date: 10 Oct 2002 04:48 PM


Dave,

Looking to the picture it seems to me you forgot the $ prefix.
You should type $current, $oldStartElement and so for.


Ivan







> -----Original Message-----
> From: stylus-studio-tech Listmanager [mailto:listmanager]
> Sent: Thursday, October 10, 2002 4:31 PM
> To: Recipients of 'stylus-studio-tech' suppressed
> Subject: watch doesn't work with variables (100g)
>
>
> From: "David Rees"
>
> Watch doesn't seem to work with variables as described. I
> don't see any values for any xpath expression that uses
> variables. This happens for built-in or the internal Xalanj.
> I've attached a screenshot.
>
> thanks,
>
> dave
>
>
>
> To reply: mailto:stylus-studio-tech.5763@edn.exln.com
> To start a new topic: mailto:stylus-studio-tech@edn.exln.com
> To login: http://edn.exln.com/~SSDN
>
>

Posttop
David ReesSubject: RE: watch doesn't work with variables (100g)
Author: David Rees
Date: 10 Oct 2002 06:43 PM
I tried it both with and without the $, but perhaps there was something else I did wrong. I any case, my 100h is "gone" and I am happy in 100k.

Thanks for the quick reply...

dave

 
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2011 All Rights Reserved.