XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Postnext
dustin niehuesSubject: XSLT mapper / Source file not showing as expected
Author: dustin niehues
Date: 30 Jun 2009 05:45 PM
I have a question about how the Source XML file is showing on the mapping pane for a new XLST style sheet. I open my xml doc in stylus studio and it shows as expected. Then I open this XML document as the Source for mapping/generating my xslt and the xml is not structured the same. Am I missing a setting somewhere?

Postnext
Ivan PedruzziSubject: XSLT mapper / Source file not showing as expected
Author: Ivan Pedruzzi
Date: 30 Jun 2009 10:17 PM

Dustin

What you see in the mapping source tree is not the entire document but rather the document structure, a sort of lightweight schema, that's why they look different.

Postnext
dustin niehuesSubject: XSLT mapper / Source file not showing as expected
Author: dustin niehues
Date: 30 Jun 2009 10:22 PM
Ivan,

Is there any way to make this less light weight of a view. Typically a user should only load a single record for the mapping process, but a record that will expose all possible mappings. My point is that this is really making it difficult for me to map the fields and it honestly doesn't look right to me (even though I am sure it is). If you can think of anything that may make this a little easier.

Thanks for the quick response too:)

Dustin

Postnext
dustin niehuesSubject: XSLT mapper / Source file not showing as expected
Author: dustin niehues
Date: 01 Jul 2009 09:57 AM
I also wanted to attach two images for you to see what I was talking about.


ImagemapperImage.gif
Mapper Image

ImageRegularXML.gif
Regular XML

UnknownNoname(45).

Postnext
Ivan PedruzziSubject: XSLT mapper / Source file not showing as expected
Author: Ivan Pedruzzi
Date: 01 Jul 2009 09:59 AM
Hi Dustin,

Can you help us understand with an example which information you are missing in tree?

Thanks!
Ivan Pedruzzi
Stylus Studio Team

Postnext
dustin niehuesSubject: XSLT mapper / Source file not showing as expected
Author: dustin niehues
Date: 01 Jul 2009 12:26 PM
I did send examples 2 mins before you sent a reply to my previous question. Just wanted to let you know.

Thanks!

Posttop
Alberto MassariSubject: XSLT mapper / Source file not showing as expected
Author: Alberto Massari
Date: 02 Jul 2009 12:26 PM
Hi Dustin,
the Mapper tree infers a schema from the source XML, and doing so it assigns all the elements that have the same name to the same element type (in order to address an XML file where each element is just one possible layout of the same global element type).
In your XML file there must be at least one Field element that contains a Record element, and this creates the loop that you are seeing.
If your XML uses the same Record name to implement a link to a different, top-level Record element, you should create an XMLSchema that illustrate this, and use that schema as Mapper source, so that the display reflects the real structure.

Hope this helps,
Alberto

 
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.