XML Editor
Sign up for a WebBoard account Sign Up Keyword Search Search More Options... Options
Chat Rooms Chat Help Help News News Log in to WebBoard Log in Not Logged in
Show tree view Topic
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Postnext
Jay StevensSubject: XPATH Query that works in 2006 Release 2 but not in Release 3
Author: Jay Stevens
Date: 02 Apr 2007 12:11 PM
This has been preventing me from using Release 3 on a regular basis for some time:

I can't get even the simplest XPATH expressions/queries to work in the Release 3 editor. What's changed? EVERYTHING that used to work in Release 2 doesn't work now. I'm guessing it has something to do with the namespaces but I can't figure it out (and I've been trying for a while).

I've attached a demo xml file that shows the problem.

The EXCRUCIATINGLY simple xpath:

//MetricQuestionsMaster

returns 2 hits in Release 2.

when executed in Release 3 it returns jack nuttin'.

Any thoughts?


DocumentTest(18).xml
Test.XML

Postnext
Alberto MassariSubject: XPATH Query that works in 2006 Release 2 but not in Release 3
Author: Alberto Massari
Date: 02 Apr 2007 01:22 PM
Hi Jay,
this is a bug in Stylus (the default namespace binding for the XHTML namespace is the reason for the wrong result - if you remove it from the XML it will start working again).
A fix will be prepared for the next update of Stylus 2007.

Thanks for reporting this bug,
Alberto

Postnext
Jay StevensSubject: XPATH Query that works in 2006 Release 2 but not in Release 3
Author: Jay Stevens
Date: 02 Apr 2007 02:42 PM
EXCELLENT! I'm not losing my mind, only my xhtml.

Posttop
Ric PullenSubject: XPATH Query that works in 2006 Release 2 but not in Release 3
Author: Ric Pullen
Date: 13 Apr 2007 08:07 AM
He mentioned 2006.... I'm having the same problem using your xpath query to clipboard.

With the rendered string it brings back nothing.... I can't test this against Release2 as I don't have it.... Is there a link to it so I can re-install?

Also you mentioned it would be fixed in the 2007 release. Does that mean that to get this bug fixed I have to purchase an upgrade to 2007?

 
Topic Page 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 Go to previous topicPrev TopicGo to next topicNext Topic
Download A Free Trial of Stylus Studio 6 XML Professional Edition Today! Powered by Stylus Studio, the world's leading XML IDE for XML, XSLT, XQuery, XML Schema, DTD, XPath, WSDL, XHTML, SQL/XML, and XML Mapping!  
go

Log In Options

Site Map | Privacy Policy | Terms of Use | Trademarks
Stylus Scoop XML Newsletter:
W3C Member
Stylus Studio® and DataDirect XQuery ™are from DataDirect Technologies, is a registered trademark of Progress Software Corporation, in the U.S. and other countries. © 2004-2016 All Rights Reserved.